Fix Weston crash on touchscreen input
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
index 2ee7150..573b481 100644 (file)
@@ -1,8 +1,10 @@
 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
 SRC_URI_append = "\
+    file://0001-compositor-drm.c-Launch-without-input-devices.patch \
     file://weston.service \
     file://weston.ini \
+    file://fix-touchscreen-crash.patch \
     "
 
 inherit systemd
@@ -13,7 +15,7 @@ SYSTEMD_SERVICE_${PN} = "weston.service"
 do_install_append() {
     # Install systemd unit files
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+        install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
     fi
 
     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston