Forward port local-arm-futex patch to poky morty HEAD
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
index 6ad42fc..0fe75ed 100644 (file)
@@ -1,26 +1,8 @@
 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
 SRC_URI_append = "\
-    file://weston.service \
-    file://weston.ini \
+    file://0001-compositor-drm.c-Launch-without-input-devices.patch \
+    file://0001-Allow-regular-users-to-launch-Weston.patch \
     "
 
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "weston.service"
-
-do_install_append() {
-    # Install systemd unit files
-    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
-    fi
-
-    WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
-    install -d ${D}${WESTON_INI_CONFIG}
-    install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-}
-
-FILES_${PN} += " \
-    ${sysconfdir}/xdg/weston/weston.ini \
-    "
+EXTRA_OECONF_append = " --enable-sys-uid"