Migrate IVI-Shell backport to Weston 1.8.0 (Yocto 2.0)
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644 (file)
index 0000000..2ee7150
--- /dev/null
@@ -0,0 +1,26 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+    file://weston.service \
+    file://weston.ini \
+    "
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "weston.service"
+
+do_install_append() {
+    # Install systemd unit files
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+    fi
+
+    WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+    install -d ${D}${WESTON_INI_CONFIG}
+    install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+    ${sysconfdir}/xdg/weston/weston.ini \
+    "