Generate weston.ini dynamically
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_%.bbappend
index 95b886c..217c4fc 100644 (file)
@@ -3,7 +3,6 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 SRC_URI_append = "\
     file://0001-compositor-drm.c-Launch-without-input-devices.patch \
     file://weston.service \
-    file://weston.ini \
     "
 
 inherit systemd
@@ -16,12 +15,4 @@ do_install_append() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
     fi
-
-    WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
-    install -d ${D}${WESTON_INI_CONFIG}
-    install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
 }
-
-FILES_${PN} += " \
-    ${sysconfdir}/xdg/weston/weston.ini \
-    "