Remove rc1 locks merge window open for rc2
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston-ini-conf.bb
index 01f2c65..c7eee62 100644 (file)
@@ -6,15 +6,16 @@ S = "${WORKDIR}"
 
 require weston-ini-conf/screen.inc
 
-DEFAULT_SCREEN[transform]?="90"
+DEFAULT_SCREEN[transform]?="270"
 DEFAULT_SCREEN[name]?="HDMI-A-1"
 
 WESTONCORE[shell]??="desktop-shell.so"
 WESTONCORE[backend]??="drm-backend.so"
 
 WESTONSHELL[locking]="true"
-# Uncomment below to hide panel
-#WESTONSHELL[panel-location]="none"
+# hide panel
+WESTONSHELL[panel-location]="none"
+
 
 WESTONOUTPUT1[agl_screen]??="DEFAULT_SCREEN"
 
@@ -49,6 +50,7 @@ python do_generate_weston_init() {
 #ar_src = d.getVarFlag('ARCHIVER_MODE', 'src', True)
 
 addtask do_generate_weston_init after do_compile before do_install
+do_generate_weston_init[vardeps] = "DEFAULT_SCREEN WESTONCORE WESTONSHELL WESTONOUTPUT1 WESTONSECTION"
 
 do_install_append() {
     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston