weston-ini-conf: Rework to use fragments to construct weston.ini
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston-ini-conf.bb
index 0edc05d..9ba49bf 100644 (file)
@@ -2,57 +2,26 @@ SUMMARY = "Startup script and systemd unit file for the Weston Wayland composito
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
 
-S = "${WORKDIR}"
-
-require weston-ini-conf/screen.inc
-
-DEFAULT_SCREEN[transform]?="270"
-DEFAULT_SCREEN[name]?="HDMI-A-1"
-
-WESTONCORE[shell]??="desktop-shell.so"
-WESTONCORE[backend]??="drm-backend.so"
-WESTONCORE[require-input]??="false"
-
-WESTONSHELL[locking]="true"
-# hide panel
-WESTONSHELL[panel-location]="none"
+SRC_URI = "file://core.cfg \
+           file://ivishell.cfg \
+           file://shell.cfg \
+           file://hdmi-a-1-270.cfg \
+          "
 
+S = "${WORKDIR}"
 
-WESTONOUTPUT1[agl_screen]??="DEFAULT_SCREEN"
-
-WESTONSECTION[WESTONCORE]?="core"
-WESTONSECTION[WESTONSHELL]?="shell"
-WESTONSECTION[WESTONOUTPUT1]?="output"
-
-python do_generate_weston_init() {
-    with open(d.getVar('WORKDIR', True)+"/weston.ini"  ,'w') as weston_ini:
-        dicoSection=d.getVarFlags('WESTONSECTION')
-        keysSection=list(dicoSection.keys())
-        keysSection.sort()
-        for section in keysSection:
-            weston_ini.writelines( "["+dicoSection[section]+"]\n")
-            dicoSectionValues=d.getVarFlags(section)
-            keysSectionValues=list(dicoSectionValues.keys())
-            keysSectionValues.sort()
-            for sectionValue in keysSectionValues:
-                if (dicoSection[section] == "output" and sectionValue == "agl_screen"):
-                    screen=dicoSectionValues[sectionValue]
-                    dicoScreenConfig=d.getVarFlags(screen)
-                    keysScreenConfig=list(dicoScreenConfig.keys())
-                    keysScreenConfig.sort()
-                    for screenConfig in keysScreenConfig:
-                        weston_ini.writelines( screenConfig+"="+dicoScreenConfig[screenConfig]+"\n")
-                else:
-                    weston_ini.writelines( str(sectionValue)+"="+str(dicoSectionValues[sectionValue])+"\n")
+PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-            weston_ini.writelines( "\n")
+do_compile() {
+    # Put all of our cfg files together.
+    rm -f ${WORKDIR}/weston.ini
+    for F in ${WORKDIR}/*.cfg; do
+        cat $F >> ${WORKDIR}/weston.ini
+        echo >> ${WORKDIR}/weston.ini
+    done
+    sed -i -e '$ d' ${WORKDIR}/weston.ini
 }
 
-#ar_src = d.getVarFlag('ARCHIVER_MODE', 'src', True)
-
-addtask do_generate_weston_init after do_compile before do_install
-do_generate_weston_init[vardeps] = "DEFAULT_SCREEN WESTONCORE WESTONSHELL WESTONOUTPUT1 WESTONSECTION"
-
 do_install_append() {
     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
     install -d ${D}${WESTON_INI_CONFIG}