Add support for cflags for pi0/1
[AGL/meta-agl.git] / meta-agl / recipes-graphics / images / agl-image-weston.bb
index a547522..427132e 100644 (file)
@@ -1,11 +1,12 @@
 SUMMARY = "A very basic Wayland image with a terminal"
 
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+require agl-image-weston.inc
 
 LICENSE = "MIT"
 
-inherit core-image distro_features_check
+IMAGE_INSTALL_append = "\
+    packagegroup-agl-image-weston \
+    "
 
-REQUIRED_DISTRO_FEATURES = "wayland"
-
-CORE_IMAGE_BASE_INSTALL += "weston weston-examples"
+DISTRO_FEATURES_append = " agl-core-image-profile"
+IMAGE_INSTALL_append = " agl-desktop-config"