agl-login-manager,agl-desktop-config: Move layer to meta-agl
[AGL/meta-agl.git] / meta-agl / recipes-graphics / agl-desktop-config / agl-desktop-config_0.1.bb
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb b/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
new file mode 100644 (file)
index 0000000..e0358d6
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY = "AGL desktop config"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += " \
+    file://user-weston-term.service \
+    file://user-weston-term.path \
+"
+
+do_install_append() {
+    install -d ${D}${systemd_user_unitdir}
+    install -m 0644 ${WORKDIR}/user-weston-term.service ${D}${systemd_user_unitdir}
+    install -m 0644 ${WORKDIR}/user-weston-term.path ${D}${systemd_user_unitdir}
+
+    install -d ${D}${systemd_user_unitdir}/default.target.wants
+    ln -sf ${systemd_user_unitdir}/user-weston-term.path ${D}${libdir}/systemd/user/default.target.wants
+}
+
+FILES_${PN} += "${systemd_user_unitdir}/*"
+FILES_${PN} += "${systemd_user_unitdir}/default.target.wants/default.target.wants"