Merge remote-tracking branch 'agl/sandbox/locust2001/rocko' into HEAD
[AGL/meta-agl.git] / meta-agl / recipes-core / systemd / systemd_%.bbappend
index ef877c0..f64ca8c 100644 (file)
@@ -1,8 +1,9 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SRC_URI += "file://e2fsck.conf \
-            ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
-           "
+SRC_URI += "\
+    file://e2fsck.conf \
+    ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
+"
 
 # enable networkd/resolved support
 PACKAGECONFIG_append_pn-systemd = " \
@@ -20,3 +21,6 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/e2fsck.conf "
+
+# SPEC-737: connmand also has a NTP client which races with systemd-timesyncd
+PACKAGECONFIG_remove = "timesyncd"