most: delete bbappend for removing skb_put_data patch
[AGL/meta-agl.git] / meta-agl / recipes-core / psplash / psplash_git.bbappend
index 3b4f851..bdc196b 100644 (file)
@@ -3,14 +3,15 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 SRC_URI += "file://psplash-colors.h \
             file://psplash-start.service \
             file://psplash-quit.service \
+            file://psplash-anim \
             "
 
 SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
 
 inherit systemd
 
-SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
-SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
+SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
 
 do_configure_append () {
        cd ${S}
@@ -18,8 +19,9 @@ do_configure_append () {
 }
 
 do_install_append () {
-    if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
         install -d ${D}${systemd_unitdir}/system
         install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
     fi
+    install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
 }