rygel: Arrange rocko
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
index bfee4f5..4ae5925 100644 (file)
@@ -5,28 +5,21 @@ PACKAGECONFIG = "media-export lms"
 PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
 
 # LightMediaScanner plugin patches
-SRC_URI += "file://0001-Add-LightMediaScanner-plugin.patch \
-            file://0002-lms-add-C-source-files.patch \
-            file://0001-Fix-missing-link-to-unistring-for-lms-plugin.patch \
-            file://rygel.service \
-            "
+SRC_URI += "\
+    file://0001-Fix-missing-link-to-unistring-for-lms-plugin.patch \
+    file://rygel.service \
+"
 
-inherit systemd
+do_install_prepend() {
+    # Install rygel systemd service
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
 
-do_install_append() {
-       # Install rygel systemd service
-       if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-              install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
-
-              # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
-              # because it does not support systemd's user mode.
-              # However, systemctl --global should be checked
-              #mkdir -p ${D}/etc/systemd/user/default.target.wants/
-              #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/dbus-org.gnome.Rygel1.service
-              #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/default.target.wants/rygel.service
-       fi
+        # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
+        # because it does not support systemd's user mode.
+        # However, systemctl --global should be checked
+        #mkdir -p ${D}/etc/systemd/user/default.target.wants/
+        #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/dbus-org.gnome.Rygel1.service
+        #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/default.target.wants/rygel.service
+    fi
 }
-
-FILES_${PN} += " \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/rygel.service', '', d)} \
-    "