Introduce meta-agl-profile-core and meta-agl-profile-graphics
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
diff --git a/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend b/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
deleted file mode 100644 (file)
index 4ae5925..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-# Disable everything but the media-export plugin, add the lms plugin
-PACKAGECONFIG = "media-export lms"
-PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
-
-# LightMediaScanner plugin patches
-SRC_URI += "\
-    file://0001-Fix-missing-link-to-unistring-for-lms-plugin.patch \
-    file://rygel.service \
-"
-
-do_install_prepend() {
-    # Install rygel systemd service
-    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
-
-        # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
-        # because it does not support systemd's user mode.
-        # However, systemctl --global should be checked
-        #mkdir -p ${D}/etc/systemd/user/default.target.wants/
-        #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/dbus-org.gnome.Rygel1.service
-        #ln -sf ${systemd_user_unitdir}/rygel.service ${D}/etc/systemd/user/default.target.wants/rygel.service
-    fi
-}