af-main: Refactor of user session management
[AGL/meta-agl.git] / meta-agl / recipes-config / agl-login-manager / agl-login-manager_0.1.bb
index 22f52c4..cd6dc67 100644 (file)
@@ -5,28 +5,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
 
 inherit agl-graphical
 
-SRC_URI += " \
-    file://user-config.service \
-    file://user-config.path \
-"
-
 LOGIN_USER ??="1001 1002"
 
 RDEPENDS_${PN} += "af-main"
 
 do_install_append() {
 
-    install -d ${D}${systemd_user_unitdir}/default.target.wants
-    install -m 0644 ${WORKDIR}/user-config.service ${D}${systemd_user_unitdir}
-    install -m 0644 ${WORKDIR}/user-config.path ${D}${systemd_user_unitdir}
-
-    sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
-        -i ${D}${systemd_user_unitdir}/user-config.service
-    sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
-        -i ${D}${systemd_user_unitdir}/user-config.path
-
-    ln -s ../user-config.path ${D}${systemd_user_unitdir}/default.target.wants/user-config.path
-
     install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
 
     for AGL_USER in ${LOGIN_USER};do
@@ -34,4 +18,4 @@ do_install_append() {
     done
 }
 
-FILES_${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir}"
+FILES_${PN} += "${systemd_system_unitdir}"