Packaging: ignore expected rpmlint warnings
[src/xds/xds-agent.git] / conf.d / packaging / rpm / agl-xds-agent.spec
index b6e3fff..47c76ad 100644 (file)
@@ -6,14 +6,16 @@
 %global debug_package %{nil}
 
 Name:           agl-xds-agent
-Version:        1.1.1
+Version:        0.0.0
 Release:        0
 License:        Apache-2.0
 Summary:        XDS agent/client tool
-Url:            https://github.com/iotbzh/xds-agent.git
-Source0:        xds-agent_linux-amd64-v%{version}_2018-04-05_112625.zip
+Url:            https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-agent.git
+Source0:        xds-agent_linux-amd64-%{version}.zip
+Source1:        rpmlintrc
 BuildRequires:  unzip
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
+Group:          Development/Tools/Debuggers
 
 # currently embedded with xds
 # Requires:       syncthing
@@ -42,8 +44,6 @@ cp ./conf.d/etc/default/xds-agent %{?buildroot}/%{_sysconfdir}/default/
 mkdir -p %{?buildroot}/%{_sysconfdir}/xds/agent
 cp ./conf.d/etc/xds/agent/* %{?buildroot}/%{_sysconfdir}/xds/agent/
 
-mkdir -p %{?buildroot}%{_userunitdir}/default.target.wants && ln -s ../xds-agent.service %{?buildroot}%{_userunitdir}/default.target.wants/
-
 mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
 sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-agent.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 
@@ -63,8 +63,6 @@ sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-agent.s
 %config %{_sysconfdir}/profile.d/%{name}.sh
 %dir %{_userunitdir}
 %{_userunitdir}/xds-agent.service
-%dir %{_userunitdir}/default.target.wants
-%{_userunitdir}/default.target.wants/xds-agent.service
 
 %post
 if [ "$1" -ge 2 ]; then