a09473ab067237a3695a34a1dfad582884141a0b
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
1 SUMMARY = "WAM"
2 AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6 inherit cmake
7
8 DEPENDS = "glib-2.0 jsoncpp boost chromium79 libhomescreen"
9
10 EXTRA_OECMAKE = "\
11     -DCMAKE_BUILD_TYPE=Release \
12     -DCMAKE_INSTALL_PREFIX=${prefix} \
13     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
14     -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium79"
15
16 PR="r0"
17
18 PROVIDES += "virtual/webruntime"
19 RPROVIDES_${PN} += "virtual/webruntime"
20
21 # Disable some of securit_flags
22 # Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
23 # Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
24 lcl_maybe_fortify = ""
25 SECURITY_STACK_PROTECTOR = ""
26
27 SRC_URI = "\
28     git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
29     file://WebAppMgr@.service \
30     file://WebAppMgr.env \
31     file://trunc-webapp-roles.patch \
32 "
33 S = "${WORKDIR}/git"
34 SRCREV = "a9f18b049d319865514f5f92b248ecdf9c09761d"
35
36 do_install_append() {
37     install -d ${D}${sysconfdir}/wam
38     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
39     install -d ${D}${systemd_system_unitdir}
40     install -v -m 644 ${WORKDIR}/WebAppMgr@.service ${D}${systemd_system_unitdir}/WebAppMgr@.service
41     install -d ${D}${sysconfdir}/default/
42     install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
43     ln -snf WebAppMgr ${D}${bindir}/web-runtime
44     install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
45     ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
46 }
47
48 FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
49
50 CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"
51
52 do_install_append_agl-devel() {
53     # Enable remote inspector and dev mode
54     install -d ${D}${localstatedir}/agl-devel/preferences
55     touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps
56     touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
57 }