81833bb34160a7b71becbb45d81b44d15ebad8af
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
1 SUMMARY = "WAM"
2 AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6 inherit cmake
7
8 DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native"
9
10 EXTRA_OECMAKE = "\
11     -DCMAKE_BUILD_TYPE=Release \
12     -DCMAKE_INSTALL_PREFIX=${prefix} \
13     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
14     -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
15
16 PR="r0"
17
18 PROVIDES += "virtual/webruntime"
19 RPROVIDES:${PN} += "virtual/webruntime"
20
21 # Disable some of securit_flags
22 # Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
23 # Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
24 lcl_maybe_fortify = ""
25 SECURITY_STACK_PROTECTOR = ""
26
27 SRC_URI = "\
28     git://github.com/igalia/${BPN}.git;branch=@52.agl.marlin;protocol=https \
29     file://WebAppMgr.service \
30     file://WebAppMgr.env \
31 "
32 S = "${WORKDIR}/git"
33 SRCREV = "0a0e6c52fa2983f4703ef9fce68b01b631003043"
34
35 do_install:append() {
36     install -v -d ${D}${sysconfdir}/wam
37     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
38     install -v -d ${D}${systemd_user_unitdir}
39     install -v -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_user_unitdir}/WebAppMgr.service
40     install -v -d ${D}${sysconfdir}/default/
41     install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
42     ln -snf WebAppMgr ${D}${bindir}/web-runtime
43     install -v -d ${D}${systemd_user_unitdir}/agl-session.target.wants
44     ln -sf ../WebAppMgr.service ${D}${systemd_user_unitdir}/agl-session.target.wants/
45 }
46
47 FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_user_unitdir}"
48
49 CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
50
51 do_install:append:agl-devel() {
52     # Enable remote inspector and dev mode
53     install -d ${D}${localstatedir}/agl-devel/preferences
54     touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps
55     touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
56 }