web-runtime: Update from chromium68 to chromium79
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium79_git.bb
1 require chromium.inc
2
3 SRC_URI = "\
4     git://github.com/igalia/${PN};branch=@45.agl.jellyfish;protocol=https;rev=${SRCREV_chromium79};name=chromium79 \
5     git://github.com/webosose/chromium-v8;branch=@chromium79;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
6     file://0001-GCC-fix-includes-for-gcc-10.patch \
7 "
8
9 # Needed by catapult
10 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
11
12 SRCREV_chromium79 = "c568380f34a275ed5430f3927b1bdee0e14220e0"
13 SRCREV_v8 = "e876fd0e28bd3bda5815394874183b7e6079d440"
14
15 BROWSER_APPLICATION = "chromium79-browser"
16 BROWSER_APPLICATION_DIR = "/opt/chromium79"
17 MKSNAPSHOT_PATH = "v8_snapshot/"
18
19 GN_ARGS += "use_gtk=false"
20
21 # Disable closure_compile
22 # Else we need HOSTTOOLS += "java"
23 GN_ARGS += "closure_compile=false"
24
25 # When using meta-clang, one can switch to using the lld linker
26 # by using the ld-is-lld distro feature otherwise use gold linker
27 GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', 'use_lld=false use_gold=true', d)}"
28
29 # Toolchains we will use for the build. We need to point to the toolchain file
30 # we've created, set the right target architecture and make sure we are not
31 # using Chromium's toolchain (bundled clang, bundled binutils etc).
32 GN_ARGS += "\
33     host_toolchain=\"//build/toolchain/cros:host\" \
34     cros_host_is_clang=false \
35     use_custom_libcxx_for_host=false \
36     cros_host_ar=\"${BUILD_AR}\" \
37     cros_host_cc=\"${BUILD_CC}\" \
38     cros_host_cxx=\"${BUILD_CXX}\" \
39     cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
40     custom_toolchain=\"//build/toolchain/cros:target\" \
41     is_clang=false \
42     use_custom_libcxx=false \
43     target_cpu=\"${@gn_arch_name('${TUNE_ARCH}')}\" \
44     cros_target_ar=\"${AR}\" \
45     cros_target_cc=\"${CC}\" \
46     cros_target_cxx=\"${CXX}\" \
47     cros_target_extra_ldflags=\"${LDFLAGS}\" \
48     v8_snapshot_toolchain=\"//build/toolchain/cros:v8_snapshot\" \
49     cros_v8_snapshot_is_clang=false \
50     cros_v8_snapshot_ar=\"${BUILD_AR}\" \
51     cros_v8_snapshot_cc=\"${BUILD_CC}\" \
52     cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
53     linux_use_bundled_binutils=false \
54     gold_path=\"\" \
55     v8_enable_embedded_builtins=false \
56     use_v8_context_snapshot=false \
57 "
58
59 D = "${OUT_DIR}/${BUILD_TYPE}/image"
60