sllin: switch to updated upstream
[AGL/meta-agl-demo.git] / recipes-support / lin-config / lin-config_git.bb
1 DESCRIPTION = "lin-config tool for the sllin driver module"
2 LICENSE = "GPL-2.0-only"
3 LIC_FILES_CHKSUM = "file://lin_config.c;beginline=4;endline=9;md5=196a29df19a30dbc752937bdfc819d7a"
4
5 DEPENDS += "libnl libxml2"
6
7 SRC_URI = "git://github.com/lin-bus/linux-lin.git;protocol=https;branch=master"
8 SRCREV = "beb057d7505e0c4d7c61f3f4927b76916ec00e88"
9 S = "${WORKDIR}/git/lin_config/src"
10
11 SRC_URI:append = " \
12         file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
13         file://0002-Change-Makefile-to-use-LDFLAGS.patch \
14         "
15
16 inherit pkgconfig
17
18 PV = "0.1+git${SRCPV}"
19
20 do_configure[noexec] = "1"
21
22 do_install:append() {
23     install -d ${D}/${bindir}
24     install -m 755 ${S}/lin_config ${D}/${bindir}
25 }