60360aa06d7f948026961d2e92acd3d31620e4f2
[AGL/meta-agl-demo.git] / recipes-qt / qml-radio-plugin / qml-radio-plugin_0.1.bb
1 SUMMARY = "AM/FM Radio QML plugin (for RTL2832U hardware)"
2 DESCRIPTION = "This provides a simple QML plugin able to detect and use radio hardware, most notable RTL2832U chipsets (although it can easily be extended). Among other things, it provides generic APIs to display status, switch between AM/FM mode, choose frequency, mute sound..."
3 HOMEPAGE = "https://github.com/iotbzh/qml_radio_plugin"
4
5 LICENSE = "GPLv2+"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7                     file://qml_radio.cpp;endline=16;md5=10a65c128e3a6cff2a61bb38556ceb04"
8
9 DEPENDS = "qtbase-native qtdeclarative rtl-sdr alsa-lib"
10 RDEPENDS_${PN} = "qtdeclarative-tools qtquickcontrols-qmlplugins"
11
12 SRC_URI = "git://github.com/iotbzh/qml_radio_plugin"
13 SRCREV = "0032dc92d1a208219a0f782b68aef7f4cbcc0028"
14 S = "${WORKDIR}/git"
15
16 inherit autotools pkgconfig
17
18 EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
19
20 QML_LIBDIR = "${libdir}/qt5/qml"
21
22 do_install_append() {
23      # Remove .la files for loadable modules
24      rm -f ${D}/${QML_LIBDIR}/radio/*.la
25      # Install QML example
26      install -d ${D}/${datadir}/qt5/examples/radio
27      install -m 0644 ${S}/radio.qml ${D}/${datadir}/qt5/examples/radio
28 }
29
30 FILES_${PN} += "${QML_LIBDIR}/radio/*.so ${QML_LIBDIR}/radio/qmldir ${datadir}"
31 FILES_${PN}-dbg += "${QML_LIBDIR}/radio/.debug"