317b90052c32455482c2529e99d462aad7d3b590
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-preload.bb
1 SUMMARY = "Extra software and configuration for tradeshow demo with AGL IVI profile demo platform"
2 LICENSE = "MIT"
3
4 inherit packagegroup
5
6 PROVIDES = "${PACKAGES}"
7 PACKAGES = " \
8     packagegroup-agl-demo-preload \
9 "
10
11 # NOTES:
12 # - demo-i2c-udev-conf:
13 #     Adds udev configuration and scripts for supporting USB attached
14 #     I2C devices for RTC and HVAC LED support.
15 # - sllin-demo:
16 #     Adds systemd unit and scripting to drive configuring sllin
17 #     driver with lin-config utility, enabling HVAC fan control and
18 #     steering wheel controls in the demo.
19 # - kuksa-dbc-feeder-sllin:
20 #     Adds configuration and systemd unit to run a second instance of
21 #     the DBC feeder against the sllin0 interface to connect the
22 #     steering wheel controls into VIS.
23 # - agl-service-hvac-demo-conf:
24 #     Adds configuration to make agl-service-hvac use sllin0 for its
25 #     HVAC board control via CAN -> LIN.
26 # - simple-can-simulator:
27 #     CAN message simulator for vehicle and engine speed message
28 #     generation, with some support for the cruise control events from
29 #     the steering wheel used in the demo setup.
30 #
31 RDEPENDS:${PN} = "\
32     packagegroup-agl-demo-platform \
33     demo-i2c-udev-conf \
34     sllin-demo \
35     kuksa-dbc-feeder-sllin \
36     agl-service-hvac-demo-conf \
37     simple-can-simulator \
38 "