25a3795086c8d19b0e91774b2cb948913db9f410
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-preload.bb
1 SUMMARY = "Extra software and configuration for tradeshow demo with AGL IVI profile demo platform"
2 LICENSE = "MIT"
3
4 inherit packagegroup
5
6 PROVIDES = "${PACKAGES}"
7 PACKAGES = " \
8     packagegroup-agl-demo-preload \
9 "
10
11 # NOTES:
12 # - demo-i2x-udev-conf:
13 #     Adds udev configuration and scripts for supporting USB attached
14 #     I2C devices for RTC and HVAC LED support.
15 # - sllin-demo:
16 #     Adds systemd unit and scripting to drive configuring sllin
17 #     driver with lin-config utility, enabling HVAC fan control and
18 #     steering wheel controls in the demo.
19 # - kuksa-dbc-feeder-sllin:
20 #     Adds configuration and systemd unit to run a second instance of
21 #     the DBC feeder against the sllin0 interface to connect the
22 #     steering wheel controls into VIS.
23 # - simple-can-simulator:
24 #     CAN message simulator for vehicle and engine speed message
25 #     generation, with some support for the cruise control events from
26 #     the steering wheel used in the demo setup.
27 #
28 RDEPENDS:${PN} = "\
29     packagegroup-agl-demo-platform \
30     demo-i2c-udev-conf \
31     sllin-demo \
32     kuksa-dbc-feeder-sllin \
33     simple-can-simulator \
34 "