a8be87b8d425a201c5983bd6116fae2f92c214c3
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-profile-graphical-qt5 \
16     packagegroup-hmi-framework \
17     packagegroup-agl-demo \
18     "
19
20 AGL_APPS = " \
21     dashboard \
22     hvac \
23     ondemandnavi \
24     settings \
25     mediaplayer \
26     messaging \
27     phone \
28     radio \
29     "
30
31 RDEPENDS:${PN}:append = " \
32     launcher \
33     qtquickcontrols2-agl \
34     qtquickcontrols2-agl-style \
35     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
36     ${AGL_APPS} \
37     psplash-portrait-config \
38     "