bb457b9935f57b8be68180dc6cb1454567657c52
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     packagegroup-agl-demo-platform-html5-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-hmi-framework \
22     packagegroup-agl-profile-graphical-html5 \
23     packagegroup-agl-demo \
24     "
25
26
27 RDEPENDS:${PN}:append = " \
28     weston-ini-conf \
29     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
30     "
31
32 # NOTE: Currently no coverage versions for the application widgets,
33 #       they should be added here when available.
34 #       Also, the navigation and mixer debug widgets are currently
35 #       specified explicitly, as there's no simple way to derive their
36 #       names from the virtual/ RPROVIDES at present.
37 RDEPENDS:${PN}-devel = " \
38     packagegroup-hmi-framework-devel \
39     "
40
41 # TODO(jdapena): replace this with HTML5 apps.
42 AGL_APPS = " \
43     dashboard \
44     html5-launcher \
45     html5-hvac \
46     ondemandnavi \
47     settings \
48     "
49
50 # TODO(jdapena): review if we still need the demo-i2c stuff.
51
52 # Hook for demo platform configuration
53 # ATM used for:
54 # 1) Adding udev configuration and scripts for supporting USB attached
55 #    I2C devices for RTC and HVAC LED support.
56 DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
57
58 # Preload only if agl-demo-preload is set
59 DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
60
61 RDEPENDS:${PN}:append = " \
62     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
63     qtquickcontrols2-agl \
64     qtquickcontrols2-agl-style \
65     ${AGL_APPS} \
66     ${DEMO_PRELOAD} \
67     "