adc08bee2fdc8b6d3622bf40fbc2e732b387aa86
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     packagegroup-agl-demo-platform-html5-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-hmi-framework \
22     packagegroup-agl-profile-graphical-html5 \
23     packagegroup-agl-demo \
24     "
25
26
27 RDEPENDS:${PN}:append = " \
28     weston-ini-conf \
29     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
30     "
31
32 # NOTE: Currently no coverage versions for the application widgets,
33 #       they should be added here when available.
34 #       Also, the navigation and mixer debug widgets are currently
35 #       specified explicitly, as there's no simple way to derive their
36 #       names from the virtual/ RPROVIDES at present.
37 RDEPENDS:${PN}-devel = " \
38     packagegroup-hmi-framework-devel \
39     "
40
41 # TODO(jdapena): replace this with HTML5 apps.
42 AGL_APPS = " \
43     dashboard \
44     hvac \
45     ondemandnavi \
46     settings \
47     "
48
49 # TODO(jdapena): review if we still need the demo-i2c stuff.
50
51 # Hook for demo platform configuration
52 # ATM used for:
53 # 1) Adding udev configuration and scripts for supporting USB attached
54 #    I2C devices for RTC and HVAC LED support.
55 DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
56
57 # Preload only if agl-demo-preload is set
58 DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
59
60 # TODO(jdapena): eventually qtquickcontrols2 components, and launcher
61 # (with an HTML5 replacement)
62 RDEPENDS:${PN}:append = " \
63     launcher \
64     qtquickcontrols2-agl \
65     qtquickcontrols2-agl-style \
66     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
67     ${AGL_APPS} \
68     ${DEMO_PRELOAD} \
69     "