02b7729c0fc457771d5fe9d62779a6bfa287f3e1
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     packagegroup-agl-demo-platform-html5-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-hmi-framework \
22     packagegroup-agl-profile-graphical-html5 \
23     "
24
25
26 RDEPENDS:${PN}:append = " \
27     weston-ini-conf \
28     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
29     "
30
31 # NOTE: Currently no coverage versions for the application widgets,
32 #       they should be added here when available.
33 #       Also, the navigation and mixer debug widgets are currently
34 #       specified explicitly, as there's no simple way to derive their
35 #       names from the virtual/ RPROVIDES at present.
36 RDEPENDS:${PN}-devel = " \
37     packagegroup-hmi-framework-devel \
38     "