d639495284005686799c6f60eba2da3c07582b6a
[AGL/meta-agl-cluster-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-platform.bb
1 SUMMARY = "The software for demo platform of AGL cluster profile"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-profile-cluster-qt5 \
16     "
17
18 # fonts
19 TTF_FONTS = " \
20     ttf-bitstream-vera \
21     ttf-dejavu-sans \
22     ttf-dejavu-sans-mono \
23     ttf-dejavu-serif \
24     source-han-sans-cn-fonts \
25     source-han-sans-jp-fonts \
26     source-han-sans-tw-fonts \
27     "
28
29 AGL_APPS = " \
30     cluster-dashboard \
31     cluster-receiver \
32     "
33
34 AGL_APIS = " \
35     agl-service-windowmanager \
36     "
37
38 RDEPENDS_${PN}_append = " \
39     wayland-ivi-extension \
40     cluster-windowmanager-conf \
41     hmi-debug \
42     libva-utils \
43     linux-firmware-ralink \
44     connman \
45     connman-client \
46     connman-tools \
47     cluster-connman-conf \
48     iproute2 \
49     dhcp-client \
50     ${TTF_FONTS} \
51     ${AGL_APPS} \
52     ${AGL_APIS} \
53 "