Rework demo packagegroup and images
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-platform-crosssdk.bb
1 require agl-ivi-demo-platform.bb
2
3 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
4
5 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
6 It includes the full meta-toolchain, plus developement headers and libraries \
7 to form a standalone cross SDK."
8
9 require recipes-platform/images/agl-image-minimal-crosssdk.inc
10
11 # Add wayland-scanner to SDK (SPEC-945)
12 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
13 # wayland-scanner is in nativesdk-wayland-dev !
14 # option: add also nativesdk-qtwayland-tools
15 TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
16
17 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
18
19 # Add qtwaylandscanner to the SDK
20 TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
21
22
23 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
24 # Both exec "createrepo" on the same directory, and so one of them
25 # can failed (randomly).
26 addtask do_populate_sdk after do_rootfs
27
28 inherit populate_sdk populate_sdk_qt5
29
30 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
31 # Both exec "createrepo" on the same directory, and so one of them
32 # can failed (randomly).
33 addtask do_populate_sdk after do_rootfs
34
35 # Add gcc-sanitizers to support building applications using the SDK with
36 # AddressSanitizer support to detect use-after-frees along with other
37 # memory issue.
38 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
39
40 TOOLCHAIN_TARGET_TASK += "waltham-dev"
41
42
43 TOOLCHAIN_HOST_TASK += " \
44     nativesdk-lua \
45 "
46
47 # Required dependencies for app and test builds
48 TOOLCHAIN_TARGET_TASK += " \
49     lua-dev \
50     lua-staticdev \
51 "