flutter-cluster-dashboard: fix KVM demo configurations
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-control-panel.bb
1 require recipes-platform/images/agl-image-weston.bb
2
3 SUMMARY = "AGL demo control panel image"
4
5 require agl-demo-features.inc
6
7 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
8
9 # NOTE: The client key and certificate in kuksa-certificates-agl-client
10 #       seem required by kuksa-client at the moment even though client
11 #       certification has been deprecated upstream, this needs further
12 #       investigation so it can be dropped from the image.
13 #   
14 IMAGE_KUKSA_PACKAGES = " \
15     kuksa-client \
16     kuksa-certificates-agl-ca \
17     kuksa-certificates-agl-client \
18 "
19
20 IMAGE_INSTALL += "\
21     packagegroup-agl-networking \
22     weston-ini-conf-landscape \
23     weston-agl-driver-conf \
24     ${IMAGE_KUKSA_PACKAGES} \
25     agl-demo-control-panel \
26     qtwayland \
27     qtwayland-plugins \
28     qtwayland-qmlplugins \
29 "