Add wireplumber recipes to agl explicitly.
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-image-ivi.bb
1 SUMMARY = "A basic system of AGL distribution of IVI profile"
2
3 DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
4
5 LICENSE = "MIT"
6
7 require recipes-platform/images/agl-image-weston.inc
8
9 IMAGE_INSTALL:append = "\
10     packagegroup-agl-image-ivi \
11     packagegroup-agl-ivi-services \
12     ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
13     ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'wireplumber-config-agl wireplumber-policy-config-agl', '', d)} \
14     can-utils \
15     iproute2 \
16     "
17
18 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
19
20 # NOTE: In hardknott or later this can be replaced by adding "weston"
21 #       to IMAGE_FEATURES.
22 SYSTEMD_DEFAULT_TARGET = "graphical.target"
23
24