mobile-broadband-provider-info: remove local patch
[AGL/meta-agl-demo.git] / recipes-multimedia / musicpd / libmpdclient_2.19.bb
1 SUMMARY = "C client library for the Music Player Daemon"
2 LICENSE = "BSD-3-Clause"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=06b9dfd2f197dc514d8ef06549684b77"
4 HOMEPAGE = "https://www.musicpd.org/libs/libmpdclient/"
5
6 inherit meson
7
8 SRC_URI = " \
9     git://github.com/MusicPlayerDaemon/libmpdclient;branch=master;protocol=https \
10 "
11 SRCREV = "27767959442ef390aabb16790494ba93fed962ef"
12 S = "${WORKDIR}/git"
13
14 PACKAGECONFIG ??= "tcp"
15 PACKAGECONFIG[tcp] = "-Dtcp=true,-Dtcp=false"
16
17 do_install:append() {
18     # libmpdclient's Vala bindings are outdated and unmaintained; it
19     # is likely that nobody will ever use them, so let's not install
20     # them
21     rm -rf ${D}${datadir}/vala
22 }