Update cluster network configuration
[AGL/meta-agl-demo.git] / recipes-kernel / sllin / sllin-demo.bb
1 DESCRIPTION = "AGL IVI demo slLIN driver configuration"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5 inherit allarch systemd
6
7 SRC_URI = " \
8     file://sllin-demo.service \
9     file://start_lin_demo.sh \
10     file://lin_config.conf \
11 "
12
13 SYSTEMD_SERVICE:${PN} = "sllin-demo.service"
14
15 do_install:append () {
16         install -d 644 ${D}/${bindir}
17         install -m 0755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
18         install -d ${D}${systemd_system_unitdir}
19         install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
20         install -d ${D}${sysconfdir}
21         install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
22 }
23
24 FILES:${PN} += " \
25     ${bindir}/start_lin_demo.sh \
26     ${sysconfdir}/lin_config.conf \
27 "
28
29 RDEPENDS:${PN} += "lin-config"