1 DESCRIPTION = "Build MOST driver"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=dab"
10 SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
11 file://0001-aim-sound-3.10.31-ltsi-backport.patch \
13 S = "${WORKDIR}/git/driver"
14 SRCREV = "c52aecbce20ccc47ee91a9bd33cf413772b3487a"
16 # The inherit of module.bbclass will automatically name module packages with
17 # "kernel-module-" prefix as required by the oe-core build environment.
19 do_install_append () {
20 # modprobe automatically at boot
21 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
22 install -d ${D}${sysconfdir}/modules-load.d
23 echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
24 echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
25 echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
26 echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
27 echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
28 echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
29 echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
30 echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf