Pin MOST related recipes for Chinook
[AGL/meta-agl-demo.git] / recipes-kernel / aim-cdev / aim-cdev.bb
1 DESCRIPTION = "Build character device driver for MOST"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
10
11 S = "${WORKDIR}/git/driver/${PN}"
12 SRCREV = "${AUTOREV}"
13
14 # Pinned branch/SRCREV for Charming Chinook
15 SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=chinook"
16 SRCREV_chinook = "61ddb0d8f200af2da56f0922ffabfa7c5627ad15"
17
18 # The inherit of module.bbclass will automatically name module packages with
19 # "kernel-module-" prefix as required by the oe-core build environment.
20
21 do_install_append () {
22     # modprobe automatically at boot
23     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
24         install -d ${D}${sysconfdir}/modules-load.d
25         echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
26     fi
27 }