Fix dependency issue of weston for m3ulcb
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-ini-conf.bbappend
1 WESTONCORE[shell] ??= "ivi-shell.so"
2
3 WESTONIVISHELL[ivi-module] ??= "ivi-controller.so"
4 WESTONIVISHELL[ivi-input-module] ??= "ivi-input-controller.so"
5
6 WESTONSECTION[WESTONIVISHELL] = "ivi-shell"
7
8 # IVI cluster and virtual display sample
9 python () {
10     if bb.utils.contains('DISTRO_FEATURES', 'virtual-display', True, False, d):
11         d.setVarFlag("WESTONCORE", "virtual", "1")
12 }
13
14 WESTONOUTPUT2[agl_screen] ??= "SCREEN_VIRTUAL"
15
16 WESTONSECTION[WESTONOUTPUT2] = "output"
17
18 SCREEN_VIRTUAL[name]?="virtual1"
19 SCREEN_VIRTUAL[mode]?="384x368@60"
20
21 # If gst-record is set, recorder flag is true
22 python () {
23     if bb.utils.contains('DISTRO_FEATURES', 'gst-record', True, False, d):
24         d.setVarFlag("SCREEN_VIRTUAL", "recorder", "true")
25 }
26
27 SCREEN_VIRTUAL[ip]?="192.168.20.99"
28 SCREEN_VIRTUAL[port]?="5005"
29 SCREEN_VIRTUAL[bitrate]?="300000"
30 SCREEN_VIRTUAL[crop]?="384x368@0x0"
31