Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-agl-driver-conf.bb
1 SUMMARY     = "Weston systemd configuration to run as agl-driver user"
2 LICENSE     = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://weston-agl-driver.conf"
6
7 S = "${WORKDIR}/sources"
8 UNPACKDIR = "${S}"
9
10 inherit systemd allarch features_check
11
12 REQUIRED_DISTRO_FEATURES = "wayland systemd"
13
14 do_configure[noexec] = "1"
15 do_compile[noexec] = "1"
16
17 do_install() {
18     # Install override drop-in
19     install -d ${D}${systemd_system_unitdir}/weston.service.d
20     install -m 0644 ${UNPACKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
21 }
22
23 FILES:${PN} += "${systemd_system_unitdir}"
24
25 RDEPENDS:${PN} += "weston agl-users"