Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-extended / agl-qemu-runner / agl-qemu-runner.bb
1 SUMMARY     = "AGL simple QEMU runner script"
2 LICENSE     = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5 inherit systemd allarch
6
7 SRC_URI = "file://agl-qemu-runner.sh \
8            file://agl-qemu-runner@.service \
9 "
10
11 S = "${WORKDIR}/sources"
12 UNPACKDIR = "${S}"
13
14 do_configure[noexec] = "1"
15 do_compile[noexec] = "1"
16
17 do_install() {
18     # Install template unit
19     install -d ${D}${systemd_system_unitdir}
20     install -m 0644 ${UNPACKDIR}/agl-qemu-runner@.service ${D}${systemd_system_unitdir}/
21
22     # Install script
23     install -D -m 0755 ${UNPACKDIR}/agl-qemu-runner.sh ${D}${sbindir}/agl-qemu-runner.sh
24 }
25
26 FILES:${PN} += "${systemd_system_unitdir}"
27
28 RDEPENDS:${PN} += "bash qemu"