kuksa-viss-client: add recipe for python3-websockets dependency
[AGL/meta-agl-demo.git] / recipes-devtools / python / python3-setuptools-scm_6.0.1.bb
1 SUMMARY = "the blessed package to manage your versions by scm tags"
2 HOMEPAGE = "https://pypi.org/project/setuptools-scm/"
3 DESCRIPTION = "setuptools_scm handles managing your Python package versions in SCM metadata instead of declaring them as the version argument or in a SCM managed file."
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
6
7 SRC_URI[sha256sum] = "d1925a69cb07e9b29416a275b9fadb009a23c148ace905b2fb220649a6c18e92"
8
9 PYPI_PACKAGE = "setuptools_scm"
10 inherit pypi setuptools3
11
12 UPSTREAM_CHECK_REGEX = "setuptools_scm-(?P<pver>.*)\.tar"
13
14 RDEPENDS:${PN} = "\
15     ${PYTHON_PN}-debugger \
16     ${PYTHON_PN}-json \
17     ${PYTHON_PN}-py \
18     ${PYTHON_PN}-setuptools \
19     ${PYTHON_PN}-toml \
20 "
21 RDEPENDS:${PN}:class-native = "\
22     ${PYTHON_PN}-setuptools-native \
23     ${PYTHON_PN}-toml-native \
24 "
25
26 BBCLASSEXTEND = "native nativesdk"