kuksa-dbc-feeder: add recipe and dependencies
[AGL/meta-agl-demo.git] / recipes-devtools / python / python3-cantools_37.0.1.bb
1 DESCRIPTION = "CAN BUS tools in Python 3."
2 HOMEPAGE = "https://github.com/eerimoq/cantools"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
5
6 SRC_URI[sha256sum] = "5852ad9fd17ddd7b1a1ce87b21b000e7f5716b358cdac4fdaca13b3e292f4c99"
7
8 PYPI_PACKAGE = "cantools"
9
10 inherit pypi setuptools3
11
12 RDEPENDS:${PN} += "\
13         ${PYTHON_PN}-can \
14         ${PYTHON_PN}-bitstruct \
15         ${PYTHON_PN}-core \
16         ${PYTHON_PN}-textparser \
17 "
18
19 CLEANBROKEN = "1"