094edf7bfd726ccc008a65ffeb6fac47dcaa31d5
[AGL/meta-agl-demo.git] / recipes-demo-hmi / qtquickcontrols2-agl / qtquickcontrols2-agl_git.bb
1 SUMMARY     = "AGL demo custom QtQuickControls2 widgets"
2 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/src/qtquickcontrols2-agl"
3 LICENSE     = "MPL-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
5
6 PV = "1.0+git${SRCPV}"
7
8 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http"
9 SRCREV = "${AUTOREV}"
10
11 # Pinned branch/SRCREV for Charming Chinook
12 SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http;branch=chinook"
13 SRCREV_chinook = "a7ac743468f50d6d2e2c3bcd275adc53b7ac26b1"
14
15 S = "${WORKDIR}/git/"
16
17 inherit qmake5
18
19 FILES_${PN} += "${OE_QMAKE_PATH_QML}/AGL/Demo/Controls/*"
20
21 RDEPENDS_${PN} += " \
22         qtquickcontrols-qmlplugins \
23         qtquickcontrols2-qmlplugins \
24         qtsvg-plugins \
25 "