5d9fc9e2e6d5020b370864e5e533eea0f7a6e5be
[AGL/meta-agl-cluster-demo.git] / recipes-demo-hmi / cluster-receiver / cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
9
10 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
11 SRCREV  = "${AGL_APP_REVISION}"
12
13 PV = "1.0+git${SRCPV}"
14 S  = "${WORKDIR}/git"
15
16 # build-time dependencies
17 DEPENDS += "wayland qtquickcontrols2 qtwebsockets libqtappfw gstreamer1.0\
18             gstreamer1.0-plugins-base gstreamer1.0-plugins-bad wayland-native\
19             wayland qtwayland qtwayland-native qtbase qtdeclarative qtquickcontrols2"
20
21 inherit cmake_qt5 pkgconfig aglwgt
22
23 RDEPENDS_${PN} += " \
24         gstreamer1.0-plugins-base \
25         gstreamer1.0-plugins-good \
26         gstreamer1.0-plugins-bad \
27 "
28
29 # VA-API may be used on Intel if present
30 RRECOMMENDS_${PN}_append_intel-corei7-64 = " gstreamer1.0-vaapi"