[homescreen] Add support for color schemes.
[AGL/meta-agl-demo.git] / recipes-demo-hmi / HomeScreen / HomeScreen_0.1.1.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
3 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 PV          = "0.1.1+gitr${SRCPV}"
7 PR          = "r1"
8 S           = "${WORKDIR}/git/"
9
10 inherit qmake5
11 DEPENDS = "qtbase"
12
13 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
14 SRCREV  = "3478f65b39560b333ba189e7d86e2c2cebfc9c7a"
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
16
17
18 do_compile_prepend(){
19     PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
20     export PATH
21 }
22
23 do_install() {
24     install -d ${D}/opt/AGL/${PN}
25     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
26     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
27
28     install -d ${D}/opt/AGL/${PN}/colorschemes
29     cp ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
30 }
31
32 FILES_${PN} += "/opt/AGL/${PN}/"
33 FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
34