mediaplayer: bump SRCREV
[AGL/meta-agl-demo.git] / recipes-demo / mediaplayer / mediaplayer_git.bb
1 SUMMARY     = "Media Player application"
2 DESCRIPTION = "AGL demonstration Media Player application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mediaplayer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "qtquickcontrols2 libqtappfw"
10
11 PV = "2.0+git${SRCPV}"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH} \
14            file://mediaplayer.conf \
15            file://mediaplayer.token \
16 "
17 SRCREV  = "0aefba20fe07dbb79d7b3683ab38c0b0b313a655"
18
19 S  = "${WORKDIR}/git"
20
21 inherit qmake5 pkgconfig agl-app
22
23 AGL_APP_NAME = "Mediaplayer"
24
25 do_install:append() {
26     # Currently using default global client and CA certificates
27     # for KUKSA.val SSL, installing app specific ones would go here.
28
29     # VIS authorization token file for KUKSA.val should ideally not
30     # be readable by other users, but currently that's not doable
31     # until a packaging/sandboxing/MAC scheme is (re)implemented or
32     # something like OAuth is plumbed in as an alternative.
33     install -d ${D}${sysconfdir}/xdg/AGL/mediaplayer
34     install -m 0644 ${WORKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
35     install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
36 }
37
38 RDEPENDS:${PN} += "libqtappfw mpd"