libqtappfw: add qtwebsockets dependency
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 SECTION     = "libs"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtbase \
11     qtdeclarative \
12     qtwebsockets \
13     glib-2.0 \
14     bluez-glib \
15     connman-glib \
16     libmpdclient \
17 "
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV  = "1332cc7d0a618ee88b4d19813340665332d406ca"
21 S       = "${WORKDIR}/git"
22
23 # PV needs to be modified with SRCPV to work AUTOREV correctly
24 PV = "2.0+git${SRCPV}"
25
26 inherit cmake_qt5 pkgconfig
27
28 RRECOMMENDS:${PN} += "bluez5 connman mpd"
29
30 BBCLASSEXTEND = "nativesdk"