Add updated demo applications back
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 SECTION     = "libs"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
10
11 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
12 SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
13 S       = "${WORKDIR}/git/"
14
15 # PV needs to be modified with SRCPV to work AUTOREV correctly
16 PV = "2.0+git${SRCPV}"
17
18 inherit cmake_qt5
19
20 BBCLASSEXTEND = "nativesdk"