1a50ba0fea27b0f3625713cd3a35b2abf0b26fcc
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 SECTION     = "libs"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtbase \
11     qtdeclarative \
12     glib-2.0 \
13     bluez-glib \
14     connman-glib \
15     libmpdclient \
16 "
17
18 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
19 SRCREV  = "0de8ac83e6a190d5fc124587d1f9f0a7f0198ce3"
20 S       = "${WORKDIR}/git"
21
22 # PV needs to be modified with SRCPV to work AUTOREV correctly
23 PV = "2.0+git${SRCPV}"
24
25 inherit cmake_qt5 pkgconfig
26
27 RRECOMMENDS:${PN} += "bluez5 connman mpd"
28
29 BBCLASSEXTEND = "nativesdk"