chromium, html5-*: adapt to kirkstone
[AGL/meta-agl-demo.git] / recipes-demo / html5-hvac / html5-hvac_git.bb
1 SUMMARY     = "AGL HTML5 HVAC Application"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-hvac/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
13   file://webapps-hvac.desktop \
14 "
15 SRCREV = "6abbe876aee09b225af9329e28b4fa2cc4d4c220"
16
17 inherit pythonnative
18
19 DEPENDS = "nodejs-native"
20
21 do_compile() {
22   cd ${S}
23   rm -rf package node_modules package-lock.json
24   npm install
25   npm run build
26 }
27
28 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
29 APPLICATIONS_DIR="${datadir}/applications"
30
31 do_install() {
32   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
33   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
34   install -d ${D}${APPLICATIONS_DIR}
35   install ${WORKDIR}/webapps-hvac.desktop ${D}${APPLICATIONS_DIR}
36 }
37
38 FILES:${PN} = " \
39   ${WAM_APPLICATIONS_DIR}/${PN} \
40   ${APPLICATIONS_DIR} \
41 "