html-homescreen: bump SRVREV
[AGL/meta-agl-demo.git] / recipes-demo / html5-homescreen / html5-homescreen_git.bb
1 SUMMARY     = "AGL HTML5 Homescreen"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-homescreen/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
13   file://homescreen.service \
14 "
15 SRCREV = "e85c42ae77592afdb72df8e8d4f27e0e7ad17bb9"
16
17 inherit pythonnative
18
19 DEPENDS = "nodejs-native"
20
21 do_compile[network] = "1"
22 do_compile() {
23   cd ${S}
24   rm -rf package node_modules package-lock.json
25   npm install
26   npm run build
27 }
28
29 WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
30
31 do_install() {
32   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
33   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
34   install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
35   install -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
36   ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
37 }
38
39 FILES:${PN} = " \
40   ${WAM_APPLICATIONS_DIR}/${PN} \
41   ${systemd_user_unitdir} \
42 "
43
44 RCONFLICTS:${PN} = "homescreen"
45 RDEPENDS:${PN} = "applaunchd html5-background"