meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
[AGL/meta-agl-demo.git] / recipes-demo / html5-homescreen / html5-homescreen_git.bb
1 SUMMARY     = "AGL HTML5 Homescreen"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-homescreen/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH} \
13   file://homescreen.service \
14 "
15 SRCREV = "${AGL_APP_REVISION}"
16
17 DEPENDS = "nodejs-native"
18
19 do_compile() {
20   bldcmd=${S}/autobuild/agl/autobuild
21   cd ${S}
22   $bldcmd build
23 }
24
25 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
26
27 do_install() {
28   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
29   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
30   install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
31   install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
32   ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
33 }
34
35 FILES_${PN} = " \
36   ${WAM_APPLICATIONS_DIR}/${PN} \
37   ${systemd_user_unitdir} \
38 "
39
40 RCONFLICTS_${PN} = "homescreen"
41 RDEPENDS_${PN} = "applaunchd html5-background"