b5118072d11e1a6b5347fa5333a9631628dc376e
[AGL/meta-agl-demo.git] / recipes-demo / html5-dashboard / html5-dashboard_git.bb
1 SUMMARY     = "AGL HTML5 dashboard Application"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-dashboard/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=master \
13   file://webapps-dashboard.desktop \
14 "
15 SRCREV = "4680db99615757df9d9cc561c9a9fc5b9b1c108a"
16
17 inherit pythonnative
18
19 DEPENDS = "nodejs-native"
20
21 do_compile[network] = "1"
22 do_compile() {
23   cd ${S}
24   rm -rf package node_modules package-lock.json
25   npm install
26   npm run build
27 }
28
29 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
30 APPLICATIONS_DIR="${datadir}/applications"
31
32 do_install() {
33   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
34   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
35   install -d ${D}${APPLICATIONS_DIR}
36   install ${WORKDIR}/webapps-dashboard.desktop ${D}${APPLICATIONS_DIR}
37 }
38
39 FILES:${PN} = " \
40   ${WAM_APPLICATIONS_DIR}/${PN} \
41   ${APPLICATIONS_DIR} \
42 "