meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
[AGL/meta-agl-demo.git] / recipes-demo / html5-background / html5-background_git.bb
1 SUMMARY     = "AGL HTML5 Homescreen"
2 HOMEPAGE    = "https://github.com/AGL-web-applications/background"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://github.com/AGL-web-applications/background.git;protocol=https;branch=master \
13   file://webapps-html5-background.desktop \
14 "
15 SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
16
17 DEPENDS = "nodejs-native"
18
19 do_compile() {
20   bldcmd=${S}/autobuild/agl/autobuild
21   cd ${S}
22   $bldcmd build
23 }
24
25 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
26 APPLICATIONS_DIR="${datadir}/applications"
27
28 do_install() {
29   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
30   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
31   install -d ${D}${APPLICATIONS_DIR}
32   install ${WORKDIR}/webapps-html5-background.desktop ${D}${APPLICATIONS_DIR}
33 }
34
35 FILES_${PN} = " \
36   ${WAM_APPLICATIONS_DIR}/${PN} \
37   ${APPLICATIONS_DIR} \
38 "
39
40 RCONFLICTS_${PN} = "homescreen"